Вставленные семейства при повторном использовании исчезают

Главная Форумы Задать вопрос Вставленные семейства при повторном использовании исчезают

В этой теме 3 ответа, 3 участника, последнее обновление  Шпилька 2 мес., 1 неделя назад.

Просмотр 4 сообщений - с 1 по 4 (из 4 всего)
  • Автор
    Сообщения
  • #9114 Score: 0

    Шпилька
    Участник
    3 pts

    Расставляю подвесы для воздуховодов, все бы хорошо, но когда это же семейство вставляю второй раз, первая партия подвесов исчезает. Пыталась даже скрепками закреплять, но… тогда скрипт не срабатывает…

    Могу приложить сам скрипт с примером, но… по ходу так со всем семействами получается…

    Как сделать так, чтобы предыдущая партия не пропадала?

    #9115 Score: 1

    Александр
    Участник
    13 pts

    Это связано с созданием элементов из динамо в проекте.Надо сделать,варианты:

    1.Этот же скрипт запускать только из динамо плеера.

    2.После выполнения скрипта из динамо,сделать изменения,после которых пропадают созданные элементы,затем закрыть скрипт, в проекте сделать откат назад.

    Этими вариантами “стирается ” память из динамо на созданные элементы в проекте.

    #9116 Score: 1

    Sche
    Участник
    32 pts

    В пакете Bakery есть нод “Family Instance By Point in Transaction”. Но я им не пользовался.

    Для таких целей у меня есть питоновский скрипт, когда-то взятый с англоязычного динамовского форума.

    Выложил сюда:

    https://www.dropbox.com/sh/md6c6r5isz96b6w/AACuM4-oMzpam-JTo_Iq3h2Qa?dl=0

     

    #9308 Score: 0

    Шпилька
    Участник
    3 pts

    Александр, Ваша схема работает!!! Ух ты, я бы сама бы не догадалась…

    Sche! Спасибо за совет!!! Вариант Александра проще…

Просмотр 4 сообщений - с 1 по 4 (из 4 всего)

Для ответа в этой теме необходимо авторизоваться.